DEV: updates popperjs 2.0.6 -> 2.9.3 (#14163)

DEV: updates popperjs 2.0.6 → 2.9.3 (#14163)

diff --git a/app/assets/javascripts/discourse/package.json b/app/assets/javascripts/discourse/package.json
index 1f66aa4..47f6f83 100644
--- a/app/assets/javascripts/discourse/package.json
+++ b/app/assets/javascripts/discourse/package.json
@@ -20,7 +20,7 @@
     "@ember/optional-features": "^1.1.0",
     "@ember/test-helpers": "^2.2.0",
     "@glimmer/component": "^1.0.0",
-    "@popperjs/core": "^2.4.4",
+    "@popperjs/core": "2.9.3",
     "@uppy/aws-s3": "^1.7.12",
     "@uppy/aws-s3-multipart": "^1.8.18",
     "@uppy/core": "^1.19.2",
diff --git a/app/assets/javascripts/select-kit/addon/components/select-kit.js b/app/assets/javascripts/select-kit/addon/components/select-kit.js
index ab579c4..a0f547c 100644
--- a/app/assets/javascripts/select-kit/addon/components/select-kit.js
+++ b/app/assets/javascripts/select-kit/addon/components/select-kit.js
@@ -925,7 +925,10 @@ export default Component.extend(
               phase: "beforeWrite",
               requires: ["computeStyles"],
               fn: ({ state }) => {
-                state.styles.popper.minWidth = `${state.rects.reference.width}px`;
+                state.styles.popper.minWidth = `${Math.max(
+                  state.rects.reference.width,
+                  220
+                )}px`;
 
                 if (state.rects.reference.width >= 300) {
                   state.styles.popper.maxWidth = `${state.rects.reference.width}px`;
@@ -934,7 +937,10 @@ export default Component.extend(
                 }
               },
               effect: ({ state }) => {
-                state.elements.popper.style.minWidth = `${state.elements.reference.offsetWidth}px`;
+                state.elements.popper.style.minWidth = `${Math.max(
+                  state.elements.reference.offsetWidth,
+                  220
+                )}px`;
 
                 if (state.elements.reference.offsetWidth >= 300) {
                   state.elements.popper.style.maxWidth = `${state.elements.reference.offsetWidth}px`;
diff --git a/app/assets/javascripts/yarn.lock b/app/assets/javascripts/yarn.lock
index 236a56c..fcc1bad 100644
--- a/app/assets/javascripts/yarn.lock
+++ b/app/assets/javascripts/yarn.lock
@@ -1215,10 +1215,10 @@
     "@nodelib/fs.scandir" "2.1.4"
     fastq "^1.6.0"
 
-"@popperjs/core@^2.4.4":
-  version "2.9.2"
-  resolved "https://registry.yarnpkg.com/@popperjs/core/-/core-2.9.2.tgz#adea7b6953cbb34651766b0548468e743c6a2353"
-  integrity sha512-VZMYa7+fXHdwIq1TDhSXoVmSPEGM/aa+6Aiq3nVVJ9bXr24zScr+NlKFKC3iPljA7ho/GAZr+d2jOf5GIRC30Q==
+"@popperjs/core@2.9.3":
+  version "2.9.3"
+  resolved "https://registry.yarnpkg.com/@popperjs/core/-/core-2.9.3.tgz#8b68da1ebd7fc603999cf6ebee34a4899a14b88e"
+  integrity sha512-xDu17cEfh7Kid/d95kB6tZsLOmSWKCZKtprnhVepjsSaCij+lM3mItSJDuuHDMbCWTh8Ejmebwb+KONcCJ0eXQ==
 
 "@simple-dom/interface@^1.4.0":
   version "1.4.0"
diff --git a/package.json b/package.json
index 6f3994f..ed1a496 100644
--- a/package.json
+++ b/package.json
@@ -9,7 +9,7 @@
     "@fortawesome/fontawesome-free": "5.11.2",
     "@highlightjs/cdn-assets": "^10.6.0",
     "@json-editor/json-editor": "^2.5.2",
-    "@popperjs/core": "v2.0.6",
+    "@popperjs/core": "v2.9.3",
     "@uppy/aws-s3": "^1.7.12",
     "@uppy/aws-s3-multipart": "^1.8.18",
     "@uppy/core": "^1.19.2",
diff --git a/public/popper.js.map b/public/popper.js.map
index 85eb4e6..d6edaa6 100644
--- a/public/popper.js.map
+++ b/public/popper.js.map
@@ -1 +1 @@

[... diff too long, it was truncated ...]

GitHub sha: f66217c0b3f3e2169946595fcf8d99cf611021a1

This commit appears in #14163 which was approved by CvX. It was merged by jjaffeux.