DEV: Upgrade highline gem to latest (PR #10471)

Currently we have pinned highline to version 1.7.0. This is the gem that we use to have an interactive command line for tasks like rake admin:create.

Upgrading to the latest version 2.0.3 will remove ruby 2.7 deprecation warnings.

I’m not sure why this gem was pinned. I manually executed a couple of our rake tasks that use this and everything seems fine.

GitHub