DEV: Upgrade Rails to 6.1.3.1 (PR #12688)

This PR fixes all the deprecations and errors when running Discourse against Rails 6.1.3.1. This PR needs DEV: Compatibility with Rails 6.1 by OsamaSayegh · Pull Request #27 · discourse/rails_failover · GitHub to be merged and released before this can be merged.

GitHub

Does this mean app/views/admin/backups/show.html.erb can be deleted?

This looks great! :star_struck:

No it’s still needed; Rails infers the template path from both the controller name and action name and it automatically renders admin/backups/show for us.