DEV: Upgrade Rails to 6.1.4.1. (PR #14098)

This pulls in a fix for CVE-2021-22942 but we’re not tagging it as a security fix because Discourse is not affected by it in production.

GitHub

I guess this is fine since the build passed!