DEV: Upgrade to Rails 6.0.3 (PR #9687)

See Fix Ruby 2.7 warnings on `MiddlewareStackProxy` by kamipo · Pull Request #38091 · rails/rails · GitHub for the breaking change that caused the issues on the first attempt to upgrade.

cc: @SamSaffron

GitHub

I see @SamSaffron did remerge a fix https://github.com/discourse/discourse/commit/609e929186c45a58e0f4ddf9b2a11ecb75b02415 is this obsolete now ?

It is, closing!