DOCS: Update min versions (PR #12932)

Update the minimum required version for ruby, pg, and redis to match what is listed in the INSTALL.md file.

GitHub