FEATURE: Add compatibility for Rails 7.0+ (PR #36)

GitHub

The title of this pull request changed from “DEV: Add compatibility for Rails 7.0+” to "FEATURE: Add compatibility for Rails 7.0+

Had to upgrade version here to make AR tests green again.

        ruby: ["2.6", "2.7", "3.0"]

(this is mostly about a change from 3.0 to "3.0" to make sure it doesn’t interpret it as just 3 and use the latest 3.x version)