FEATURE: update base image to Ruby 2.6.1

FEATURE: update base image to Ruby 2.6.1

Due to Logster 2.1.0 causes segfault running unicorn in discourse_dev docker image - dev - Discourse Meta we are stuck upgrading base image.

Fix for 14634 by tenderlove · Pull Request #40 · github/ruby · GitHub by @tenderlove is backported to 2.5 but we are still waiting on 2.5.4

To avoid a custom patch in our image I opted to move base to 2.6.1 and pick up the fix direct from 2.6

diff --git a/image/base/Dockerfile b/image/base/Dockerfile
index 8e04bda..4cfda1d 100644
--- a/image/base/Dockerfile
+++ b/image/base/Dockerfile
@@ -68,13 +68,13 @@ RUN apt-get -y install ruby &&\
     echo 'gem: --no-document' >> /usr/local/etc/gemrc &&\
     mkdir /src && cd /src && git clone https://github.com/sstephenson/ruby-build.git &&\
     cd /src/ruby-build && ./install.sh &&\
-    cd / && rm -rf /src/ruby-build && (ruby-build 2.5.2 /usr/local) &&\
+    cd / && rm -rf /src/ruby-build && (ruby-build 2.6.1 /usr/local) &&\
     apt-get -y remove ruby
 
 RUN gem update --system
 
 RUN gem install bundler --force &&\
-    rm -rf /usr/local/share/ri/2.5.2/system &&\
+    rm -rf /usr/local/share/ri/2.6.1/system &&\
     cd / && git clone https://github.com/discourse/pups.git
 
 ADD install-redis /tmp/install-redis

GitHub sha: 2ad250b8

3 Likes