FIX: Add `sassc-rails` for plugins using sprockets to compile scss

FIX: Add sassc-rails for plugins using sprockets to compile scss

This did not affect core because we have a custom stylesheet pipeline

diff --git a/Gemfile b/Gemfile
index 44c6dc8..176941d 100644
--- a/Gemfile
+++ b/Gemfile
@@ -191,6 +191,7 @@ gem 'logstash-logger', require: false
 gem 'logster'
 
 gem 'sassc', require: false
+gem "sassc-rails"
 
 gem 'rotp'
 gem 'rqrcode'
diff --git a/Gemfile.lock b/Gemfile.lock
index 3ce0e45..29b8109 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -384,6 +384,12 @@ GEM
     sassc (2.0.1)
       ffi (~> 1.9)
       rake
+    sassc-rails (2.1.0)
+      railties (>= 4.0.0)
+      sassc (>= 2.0)
+      sprockets (> 3.0)
+      sprockets-rails
+      tilt
     sawyer (0.8.1)
       addressable (>= 2.3.5, < 2.6)
       faraday (~> 0.8, < 1.0)
@@ -539,6 +545,7 @@ DEPENDENCIES
   ruby-readability
   sanitize
   sassc
+  sassc-rails
   seed-fu
   shoulda
   sidekiq

GitHub sha: 59491f30

2 Likes

This commit has been mentioned on Discourse Meta. There might be relevant details there:

1 Like