FIX: Do not require trust level to invite to group (PR #13230)

It used to require SiteSetting.min_trust_level_to_allow_invite to invite a user to a group, even if the user existed and the inviter was a group owner.

GitHub

This pull request has been mentioned on Discourse Meta. There might be relevant details there: