FIX: Don't swallow an error if we can't run `yarn ember build`

FIX: Don’t swallow an error if we can’t run yarn ember build

diff --git a/lib/tasks/assets.rake b/lib/tasks/assets.rake
index d6b6c34..270ae80 100644
--- a/lib/tasks/assets.rake
+++ b/lib/tasks/assets.rake
@@ -229,7 +229,15 @@ def copy_ember_cli_assets
   assets = {}
   files = {}
 
-  system("yarn --cwd #{ember_dir} run ember build -prod")
+  unless system("yarn --cwd #{ember_dir} install")
+    STDERR.puts "Error running yarn install"
+    exit 1
+  end
+
+  unless system("yarn --cwd #{ember_dir} run ember build -prod")
+    STDERR.puts "Error running ember build"
+    exit 1
+  end
 
   # Copy assets and generate manifest data
   Dir["#{ember_cli_assets}**/*"].each do |f|

GitHub sha: 3fdb64184b1f342ca0e3e65f2b055ccb949281ce

This commit appears in #13973 which was approved by Falco. It was merged by eviltrout.