FIX: Don't try to boot the ember app on old browsers (#14423)

FIX: Don’t try to boot the ember app on old browsers (#14423)

diff --git a/app/assets/javascripts/discourse/public/assets/scripts/discourse-boot.js b/app/assets/javascripts/discourse/public/assets/scripts/discourse-boot.js
index f33a20a..a1fe1eb 100644
--- a/app/assets/javascripts/discourse/public/assets/scripts/discourse-boot.js
+++ b/app/assets/javascripts/discourse/public/assets/scripts/discourse-boot.js
@@ -1,4 +1,7 @@
 (function () {
+  if (window.unsupportedBrowser) {
+    throw "Unsupported browser detected";
+  }
   // TODO: These are needed to load plugins because @ember has its own loader.
   // We should find a nicer way to do this.
   const EMBER_MODULES = {

GitHub sha: 38b8eb59712b76d085d5e35acd091b0555e28dfc

This commit appears in #14423 which was approved by eviltrout. It was merged by Falco.