FIX: Don't use an old version of rubocop-discourse

FIX: Don’t use an old version of rubocop-discourse

Looks like rubocop-discourse 2 was released a couple of months ago, but we never updated it here causing CI to break. This change removes the version constraint because we also aren’t specifying a version in the discourse/discourse gemfile.

diff --git a/discourse_api.gemspec b/discourse_api.gemspec
index b61bd87..3438682 100644
--- a/discourse_api.gemspec
+++ b/discourse_api.gemspec
@@ -31,8 +31,8 @@ Gem::Specification.new do |spec|
   spec.add_development_dependency 'rubocop', '~> 0.69'
   spec.add_development_dependency 'simplecov', '~> 0.11'
   spec.add_development_dependency 'webmock', '~> 2.0'
-  spec.add_development_dependency 'rubocop-discourse', '~> 1.0'
-  spec.add_development_dependency 'rubocop-rspec', '~> 1.0'
+  spec.add_development_dependency 'rubocop-discourse'
+  spec.add_development_dependency 'rubocop-rspec'
 
   spec.required_ruby_version = '>= 2.2.3'
 end

GitHub sha: c6934209

This fixes an error I mentioned here: