FIX: Pin plugin version when running discourse <= 2.8.0.beta1 (#226)

FIX: Pin plugin version when running discourse <= 2.8.0.beta1 (#226)

https://github.com/discourse/discourse-assign/commit/c396605d2fc18c6d05743ce3ca750ca8a37ba21b introduces a call to the TopicView.on_preload method which was added in discourse 2.8.0.beta2.

This commit pins the plugin to the commit before the one linked above for Discourse instances running version 2.8.0.beta1 or older

diff --git a/.discourse-compatibility b/.discourse-compatibility
index 68c08e2..ece4870 100644
--- a/.discourse-compatibility
+++ b/.discourse-compatibility
@@ -1,3 +1,4 @@
+2.8.0.beta1: 54c670536c416ac1acfd6fb24d6aa0e48cc1ef18
 2.7.0.beta3: b3367ba9d2232e00f2ae66d4c4da5787c039f953
 2.7.0.beta1: 60ef0c8f418eaf892a222ca673233fee7d08671d
 2.6.0.beta1: e78537ac4634c8a4ca085144b2af76c7e60bc066

GitHub sha: 0cda263a710b2047b616c0c05cd0e392bd29e8ff

This commit appears in #226 which was approved by CvX. It was merged by OsamaSayegh.