FIX: Remove expired LE root cert from our local validation (PR #576)

The old root was getting openssl confused, resulting in a new certificate on every rebuild that could easily trigger existing let’s encrypt rate-limits.

Fixes Test for valid cert to enable force_https is broken, leaving it off when it should be on - bug - Discourse Meta

GitHub