FIX: Resolve issues running qunit via rake (PR #10922)

discourse-perspective-api was not successfully running tests via the qunit:test rake task due to inconsistent naming between core and the plugin repo.

Main question here is: will changing this break anything except old installs of this plugin on the previous repo name? I can’t think of any reasons not to make this change, but I very well may be missing something.

There’s also this: https://github.com/discourse/discourse/blob/58e17d7eab3563d437fa0015a3a871d3d756eee3/lib/tasks/plugin.rake#L16

I’m assuming this is not necessary anymore once the change in metadata.rb is made. If so, I’ll remove that line too.

GitHub

I am fairly certain this is safe.