FIX: rss gem is bundled gem since Ruby 3 (#14350)

FIX: rss gem is bundled gem since Ruby 3 (#14350)

  • FIX: rss gem is bundled gem since Ruby 3

Refer https://github.com/ruby/ruby/pull/2832

diff --git a/Gemfile b/Gemfile
index 9c2ff7c..e09839e 100644
--- a/Gemfile
+++ b/Gemfile
@@ -210,6 +210,9 @@ gem 'gc_tracer', require: false, platform: :mri
 # required for feed importing and embedding
 gem 'ruby-readability', require: false
 
+# rss gem is a bundled gem from Ruby 3 onwards
+gem 'rss', require: false
+
 gem 'stackprof', require: false, platform: :mri
 gem 'memory_profiler', require: false, platform: :mri
 
diff --git a/Gemfile.lock b/Gemfile.lock
index ae8e1ea..68f050a 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -380,6 +380,8 @@ GEM
       rspec-mocks (~> 3.10)
       rspec-support (~> 3.10)
     rspec-support (3.10.2)
+    rss (0.2.9)
+      rexml
     rswag-specs (2.4.0)
       activesupport (>= 3.1, < 7.0)
       json-schema (~> 2.2)
@@ -581,6 +583,7 @@ DEPENDENCIES
   rspec
   rspec-html-matchers
   rspec-rails
+  rss
   rswag-specs
   rtlit
   rubocop-discourse

GitHub sha: a29a6522d04dd36a16a660ea0ecde99a38bfb2e5

This commit appears in #14350 which was approved by tgxworld. It was merged by tgxworld.