FIX: Use the no-sandbox flag when running Ember CLI tests. (#12951)

FIX: Use the no-sandbox flag when running Ember CLI tests. (#12951)

Without this flag we get “Error: Browser exited unexpectedly” when trying to run tests.

diff --git a/app/assets/javascripts/discourse/testem.js b/app/assets/javascripts/discourse/testem.js
index 67efe36..b6be26b 100644
--- a/app/assets/javascripts/discourse/testem.js
+++ b/app/assets/javascripts/discourse/testem.js
@@ -6,7 +6,7 @@ module.exports = {
   browser_args: {
     Chrome: [
       // --no-sandbox is needed when running Chrome inside a container
-      process.env.CI ? "--no-sandbox" : null,
+      process.env.CI || process.env.EMBER_CLI ? "--no-sandbox" : null,
       "--headless",
       "--disable-dev-shm-usage",
       "--disable-software-rasterizer",

GitHub sha: c8f34db6

This commit appears in #12951 which was approved by eviltrout. It was merged by romanrizzi.