for docs, normalize on space after code fence when specifying lang

for docs, normalize on space after code fence when specifying lang

diff --git a/config/locales/server.en.yml b/config/locales/server.en.yml
index 4ba98aa..e0b34fe 100644
--- a/config/locales/server.en.yml
+++ b/config/locales/server.en.yml
@@ -2412,7 +2412,7 @@ en:
         This post was flagged by the community and a staff member opted to remove it.
 
         [details="Click to expand removed post"]
-        `‍``markdown
+        `‍`` markdown
         %{flagged_post_raw_content}
         `‍``
         [/details]
@@ -2473,7 +2473,7 @@ en:
 
         Here's the log:
 
-        `‍``text
+        `‍`` text
         %{logs}
         `‍``
 
@@ -2485,7 +2485,7 @@ en:
 
         Here's the log:
 
-        `‍``text
+        `‍`` text
         %{logs}
         `‍``
 
@@ -2497,7 +2497,7 @@ en:
 
         Here's the log:
 
-        `‍``text
+        `‍`` text
         %{logs}
         `‍``
 
@@ -2509,7 +2509,7 @@ en:
 
         Here's the log:
 
-        `‍``text
+        `‍`` text
         %{logs}
         `‍``
 
@@ -2526,7 +2526,7 @@ en:
 
         Here's the log:
 
-        `‍``text
+        `‍`` text
         %{logs}
         `‍``
 
@@ -2771,7 +2771,7 @@ en:
 
       ### Details
 
-      `‍``text
+      `‍`` text
       %{raw}
       `‍``
 
diff --git a/docs/INSTALL-cloud.md b/docs/INSTALL-cloud.md
index 1813c79..c2dd80f 100644
--- a/docs/INSTALL-cloud.md
+++ b/docs/INSTALL-cloud.md
@@ -117,7 +117,7 @@ You will get email reminders as new versions of Discourse are released. Please s
 
 The `launcher` command in the `/var/discourse` folder can be used for various kinds of maintenance:
 
-`‍``
+`‍`` text
 Usage: launcher COMMAND CONFIG [--skip-prereqs] [--docker-args STRING]
 Commands:
     start:      Start/initialize a container
diff --git a/docs/TROUBLESHOOTING.md b/docs/TROUBLESHOOTING.md
index 8f4366a..b58603c 100644
--- a/docs/TROUBLESHOOTING.md
+++ b/docs/TROUBLESHOOTING.md
@@ -47,7 +47,7 @@ reaching out to the community for help:
 
 9. Are you having problems bundling:
 
-`‍``
+`‍`` text
 ArgumentError: invalid byte sequence in US-ASCII
 An error occurred while installing active_model_serializers (0.7.0), and Bundler cannot continue.
 Make sure that `gem install active_model_serializers -v '0.7.0'` succeeds before bundling.
@@ -55,14 +55,14 @@ Make sure that `gem install active_model_serializers -v '0.7.0'` succeeds before
 
    Try this in console:
 
-`‍``
+`‍`` text
 $ export LANG="en_US.UTF-8"
 $ export LC_ALL="en_US.UTF-8"
 `‍``
 
    And/or this in top of `Gemfile`:
 
-`‍``
+`‍`` text
 if RUBY_VERSION =~ /1.9/
 Encoding.default_external = Encoding::UTF_8
 Encoding.default_internal = Encoding::UTF_8
diff --git a/plugins/discourse-details/README.md b/plugins/discourse-details/README.md
index 8018a66..13ea643 100644
--- a/plugins/discourse-details/README.md
+++ b/plugins/discourse-details/README.md
@@ -9,7 +9,7 @@ NOTE: Does not work on IE9, but we don't support IE9 as of Jan 1 2016.
 In your posts, surround text with `[details=your summary]` ... `[/details]`.
 For example:
 
-`‍``
+`‍`` text
    I watched the murder mystery on TV last night. [details=Who did it?]The butler did it[/details].
 `‍``
 
diff --git a/script/benchmarks/markdown/most_features.md b/script/benchmarks/markdown/most_features.md
index 592a45c..9f2924a 100644
--- a/script/benchmarks/markdown/most_features.md
+++ b/script/benchmarks/markdown/most_features.md
@@ -96,7 +96,7 @@ console.log(foo(5));
 `‍``
 
 
-`‍``text
+`‍`` text
 var foo = function (bar) {
   return bar++;
 };

GitHub sha: 444bc466