Revert "DEV: enforces no-var (#40)"

Revert “DEV: enforces no-var (#40)”

This reverts commit 4bc6acd587b9c83e7ee96a63db65b1021c78ee59.

diff --git a/assets/javascripts/discourse/controllers/admin-plugins-patreon.js.es6 b/assets/javascripts/discourse/controllers/admin-plugins-patreon.js.es6
index 3f9d164..7df0324 100644
--- a/assets/javascripts/discourse/controllers/admin-plugins-patreon.js.es6
+++ b/assets/javascripts/discourse/controllers/admin-plugins-patreon.js.es6
@@ -42,7 +42,7 @@ export default Ember.Controller.extend({
         data: rule.getProperties("group_id", "rewards_ids"),
       })
         .then(() => {
-          let obj = model.find(
+          var obj = model.find(
             (x) => x.get("group_id") === rule.get("group_id")
           );
           const rewards = rule.get("reward_list").filter(Boolean);
@@ -71,7 +71,7 @@ export default Ember.Controller.extend({
         data: rule.getProperties("group_id"),
       })
         .then(() => {
-          let obj = model.find(
+          var obj = model.find(
             (x) => x.get("group_id") === rule.get("group_id")
           );
           model.removeObject(obj);
diff --git a/package.json b/package.json
index 16057b1..326dec0 100644
--- a/package.json
+++ b/package.json
@@ -5,6 +5,6 @@
   "author": "Discourse",
   "license": "MIT",
   "devDependencies": {
-    "eslint-config-discourse": "^1.1.6"
+    "eslint-config-discourse": "^1.1.3"
   }
 }
diff --git a/yarn.lock b/yarn.lock
index 25b37db..c223bee 100644
--- a/yarn.lock
+++ b/yarn.lock
@@ -498,10 +498,10 @@ escape-string-regexp@^1.0.5:
   resolved "https://registry.yarnpkg.com/escape-string-regexp/-/escape-string-regexp-1.0.5.tgz#1b61c0562190a8dff6ae3bb2cf0200ca130b86d4"
   integrity sha1-G2HAViGQqN/2rjuyzwIAyhMLhtQ=
 
-eslint-config-discourse@^1.1.6:
-  version "1.1.6"
-  resolved "https://registry.yarnpkg.com/eslint-config-discourse/-/eslint-config-discourse-1.1.6.tgz#3080da848de09a0e533076b817d9cf865df7d571"
-  integrity sha512-K14qBtyJJeL/5njtksnSgViuTZWk3hjO1kOTqV2iTpukeRlItfJpeOpUhkwm08SBDYEKCH2Ahn/XYWR0RZ75zA==
+eslint-config-discourse@^1.1.3:
+  version "1.1.3"
+  resolved "https://registry.yarnpkg.com/eslint-config-discourse/-/eslint-config-discourse-1.1.3.tgz#38b85e810cad72280073d659565bf25611331ac3"
+  integrity sha512-n6ZRuFPMVn+jHpszZhNQwFRsIG1mRq5LrFdbN/WNDW7ohk+iyYyLkwB8btJFms5CcfHLsiiey92EAh3oNavrpw==
   dependencies:
     babel-eslint "^10.1.0"
     ember-template-lint "^2.11.0"
@@ -511,7 +511,7 @@ eslint-config-discourse@^1.1.6:
     eslint-plugin-ember "^6.10.0"
     eslint-plugin-lodash "^7.1.0"
     eslint-plugin-node "^8.0.0"
-    prettier "2.1.2"
+    prettier "^2.1.1"
 
 eslint-plugin-discourse-ember@latest:
   version "0.0.3"
@@ -1204,10 +1204,10 @@ prelude-ls@~1.1.2:
   resolved "https://registry.yarnpkg.com/prelude-ls/-/prelude-ls-1.1.2.tgz#21932a549f5e52ffd9a827f570e04be62a97da54"
   integrity sha1-IZMqVJ9eUv/ZqCf1cOBL5iqX2lQ=
 
-prettier@2.1.2:
-  version "2.1.2"
-  resolved "https://registry.yarnpkg.com/prettier/-/prettier-2.1.2.tgz#3050700dae2e4c8b67c4c3f666cdb8af405e1ce5"
-  integrity sha512-16c7K+x4qVlJg9rEbXl7HEGmQyZlG4R9AgP+oHKRMsMsuk8s+ATStlf1NpDqyBI1HpVyfjLOeMhH2LvuNvV5Vg==
+prettier@^2.1.1:
+  version "2.1.1"
+  resolved "https://registry.yarnpkg.com/prettier/-/prettier-2.1.1.tgz#d9485dd5e499daa6cb547023b87a6cf51bee37d6"
+  integrity sha512-9bY+5ZWCfqj3ghYBLxApy2zf6m+NJo5GzmLTpr9FsApsfjriNnS2dahWReHMi7qNPhhHl9SYHJs2cHZLgexNIw==
 
 progress@^2.0.0:
   version "2.0.3"

GitHub sha: 750d14d8

:+1: