Revert "DEV: upgrades sassc to 2.4.0 (#10447)"

Revert “DEV: upgrades sassc to 2.4.0 (#10447)”

We suspect it could be the cause of some issues with themes.

This reverts commit 2fac77cc488011925d8d972595c997bd0cef869f.

diff --git a/Gemfile b/Gemfile
index 050a814..19bd41d 100644
--- a/Gemfile
+++ b/Gemfile
@@ -218,7 +218,9 @@ gem 'logstash-event', require: false
 gem 'logstash-logger', require: false
 gem 'logster'
 
-gem 'sassc', '2.4.0', require: false
+# NOTE: later versions of sassc are causing a segfault, possibly dependent on processer architecture
+# and until resolved should be locked at 2.0.1
+gem 'sassc', '2.0.1', require: false
 gem "sassc-rails"
 
 gem 'rotp', require: false
diff --git a/Gemfile.lock b/Gemfile.lock
index 3edcc0a..9f053ca 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -376,8 +376,9 @@ GEM
       crass (~> 1.0.2)
       nokogiri (>= 1.8.0)
       nokogumbo (~> 2.0)
-    sassc (2.4.0)
+    sassc (2.0.1)
       ffi (~> 1.9)
+      rake
     sassc-rails (2.1.2)
       railties (>= 4.0.0)
       sassc (>= 2.0)
@@ -543,7 +544,7 @@ DEPENDENCIES
   ruby-prof
   ruby-readability
   rubyzip
-  sassc (= 2.4.0)
+  sassc (= 2.0.1)
   sassc-rails
   seed-fu
   shoulda-matchers

GitHub sha: 0f63a61f