SECURITY: Upgrading Rails version to 5.2.2.1

SECURITY: Upgrading Rails version to 5.2.2.1

diff --git a/Gemfile b/Gemfile
index 45af6c0..5ee5675 100644
--- a/Gemfile
+++ b/Gemfile
@@ -14,13 +14,13 @@ if rails_master?
 else
   # until rubygems gives us optional dependencies we are stuck with this
   # bundle update actionmailer actionpack actionview activemodel activerecord activesupport railties
-  gem 'actionmailer', '5.2.2'
-  gem 'actionpack', '5.2.2'
-  gem 'actionview', '5.2.2'
-  gem 'activemodel', '5.2.2'
-  gem 'activerecord', '5.2.2'
-  gem 'activesupport', '5.2.2'
-  gem 'railties', '5.2.2'
+  gem 'actionmailer', '5.2.2.1'
+  gem 'actionpack', '5.2.2.1'
+  gem 'actionview', '5.2.2.1'
+  gem 'activemodel', '5.2.2.1'
+  gem 'activerecord', '5.2.2.1'
+  gem 'activesupport', '5.2.2.1'
+  gem 'railties', '5.2.2.1'
   gem 'sprockets-rails'
 end
 
diff --git a/Gemfile.lock b/Gemfile.lock
index 299c7f9..86c23f2 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -1,37 +1,37 @@
 GEM
   remote: https://rubygems.org/
   specs:
-    actionmailer (5.2.2)
-      actionpack (= 5.2.2)
-      actionview (= 5.2.2)
-      activejob (= 5.2.2)
+    actionmailer (5.2.2.1)
+      actionpack (= 5.2.2.1)
+      actionview (= 5.2.2.1)
+      activejob (= 5.2.2.1)
       mail (~> 2.5, >= 2.5.4)
       rails-dom-testing (~> 2.0)
-    actionpack (5.2.2)
-      actionview (= 5.2.2)
-      activesupport (= 5.2.2)
+    actionpack (5.2.2.1)
+      actionview (= 5.2.2.1)
+      activesupport (= 5.2.2.1)
       rack (~> 2.0)
       rack-test (>= 0.6.3)
       rails-dom-testing (~> 2.0)
       rails-html-sanitizer (~> 1.0, >= 1.0.2)
-    actionview (5.2.2)
-      activesupport (= 5.2.2)
+    actionview (5.2.2.1)
+      activesupport (= 5.2.2.1)
       builder (~> 3.1)
       erubi (~> 1.4)
       rails-dom-testing (~> 2.0)
       rails-html-sanitizer (~> 1.0, >= 1.0.3)
     active_model_serializers (0.8.4)
       activemodel (>= 3.0)
-    activejob (5.2.2)
-      activesupport (= 5.2.2)
+    activejob (5.2.2.1)
+      activesupport (= 5.2.2.1)
       globalid (>= 0.3.6)
-    activemodel (5.2.2)
-      activesupport (= 5.2.2)
-    activerecord (5.2.2)
-      activemodel (= 5.2.2)
-      activesupport (= 5.2.2)
+    activemodel (5.2.2.1)
+      activesupport (= 5.2.2.1)
+    activerecord (5.2.2.1)
+      activemodel (= 5.2.2.1)
+      activesupport (= 5.2.2.1)
       arel (>= 9.0)
-    activesupport (5.2.2)
+    activesupport (5.2.2.1)
       concurrent-ruby (~> 1.0, >= 1.0.2)
       i18n (>= 0.7, < 2)
       minitest (~> 5.1)
@@ -308,9 +308,9 @@ GEM
     rails_multisite (2.0.6)
       activerecord (> 4.2, < 6)
       railties (> 4.2, < 6)
-    railties (5.2.2)
-      actionpack (= 5.2.2)
-      activesupport (= 5.2.2)
+    railties (5.2.2.1)
+      actionpack (= 5.2.2.1)
+      activesupport (= 5.2.2.1)
       method_source
       rake (>= 0.8.7)
       thor (>= 0.19.0, < 2.0)
@@ -446,13 +446,13 @@ PLATFORMS
   ruby
 
 DEPENDENCIES
-  actionmailer (= 5.2.2)
-  actionpack (= 5.2.2)
-  actionview (= 5.2.2)
+  actionmailer (= 5.2.2.1)
+  actionpack (= 5.2.2.1)
+  actionview (= 5.2.2.1)
   active_model_serializers (~> 0.8.3)
-  activemodel (= 5.2.2)
-  activerecord (= 5.2.2)
-  activesupport (= 5.2.2)
+  activemodel (= 5.2.2.1)
+  activerecord (= 5.2.2.1)
+  activesupport (= 5.2.2.1)
   annotate
   aws-sdk-s3
   aws-sdk-sns
@@ -525,7 +525,7 @@ DEPENDENCIES
   rack-mini-profiler
   rack-protection
   rails_multisite
-  railties (= 5.2.2)
+  railties (= 5.2.2.1)
   rake
   rb-fsevent
   rb-inotify (~> 0.9)

GitHub sha: bd8e46a9

3 Likes