tweaks required to get this to build... ruby now needs ruby to install ruby

tweaks required to get this to build… ruby now needs ruby to install ruby

From 364611f7ccb250bb5f3e2dd608570b14ecd1517b Mon Sep 17 00:00:00 2001
From: Sam <sam.saffron@gmail.com>
Date: Thu, 18 Oct 2018 17:41:24 +1100
Subject: [PATCH] tweaks required to get this to build... ruby now needs ruby
 to install ruby


diff --git a/image/base/Dockerfile b/image/base/Dockerfile
index e2d88e6..7ab5907 100644
--- a/image/base/Dockerfile
+++ b/image/base/Dockerfile
@@ -64,10 +64,12 @@ RUN mkdir /jemalloc-new && cd /jemalloc-new &&\
       tar -xjf jemalloc-5.1.0.tar.bz2 && cd jemalloc-5.1.0 && ./configure --prefix=/usr --with-install-suffix=5.1.0 && make build_lib && make install_lib &&\
       cd / && rm -rf /jemalloc-new
 
-RUN echo 'gem: --no-document' >> /usr/local/etc/gemrc &&\
+RUN apt-get -y install ruby &&\
+    echo 'gem: --no-document' >> /usr/local/etc/gemrc &&\
     mkdir /src && cd /src && git clone https://github.com/sstephenson/ruby-build.git &&\
     cd /src/ruby-build && ./install.sh &&\
-    cd / && rm -rf /src/ruby-build && (ruby-build 2.5.2 /usr/local)
+    cd / && rm -rf /src/ruby-build && (ruby-build 2.5.2 /usr/local) &&\
+    apt-get -y remove ruby
 
 RUN gem update --system
 
diff --git a/image/base/install-imagemagick b/image/base/install-imagemagick
index 01fff96..bb9d483 100755
--- a/image/base/install-imagemagick
+++ b/image/base/install-imagemagick
@@ -10,7 +10,7 @@ WDIR=/tmp/imagemagick
 mkdir -p $WDIR
 
 # Build and install libpng
-git clone -b v1.6.35 https://github.com/glennrp/libpng.git $WDIR/libpng
+git clone -b v1.6.34 https://github.com/glennrp/libpng.git $WDIR/libpng
 cd $WDIR/libpng
 ./autogen.sh
 ./configure --prefix=$PREFIX

GitHub

1 Like