Update the template for plugin generator to be rubocop compliant

Update the template for plugin generator to be rubocop compliant

diff --git a/lib/generators/plugin/templates/plugin.rb.erb b/lib/generators/plugin/templates/plugin.rb.erb
index d081152..bee7fa4 100644
--- a/lib/generators/plugin/templates/plugin.rb.erb
+++ b/lib/generators/plugin/templates/plugin.rb.erb
@@ -4,15 +4,15 @@
 # authors: <%= @github_username %>
 # url: https://github.com/<%= @github_username %>
 
-register_asset "stylesheets/common/<%= dasherized_name %>.scss"
-register_asset "stylesheets/desktop/<%= dasherized_name %>.scss"
-register_asset "stylesheets/mobile/<%= dasherized_name %>.scss"
+register_asset 'stylesheets/common/<%= dasherized_name %>.scss'
+register_asset 'stylesheets/desktop/<%= dasherized_name %>.scss'
+register_asset 'stylesheets/mobile/<%= dasherized_name %>.scss'
 
 enabled_site_setting :<%= underscored_name %>_enabled
 
-PLUGIN_NAME ||= "<%= classified_name %>".freeze
+PLUGIN_NAME ||= '<%= classified_name %>'.freeze
 
-load File.expand_path('../lib/<%= dasherized_name %>/engine.rb', __FILE__)
+load File.expand_path('lib/<%= dasherized_name %>/engine.rb', __dir__)
 
 after_initialize do
   # https://github.com/discourse/discourse/blob/master/lib/plugin/instance.rb

GitHub sha: 32a11a93