UX: Translating poll chart types wasn't possible

UX: Translating poll chart types wasn’t possible

diff --git a/plugins/poll/assets/javascripts/controllers/poll-ui-builder.js.es6 b/plugins/poll/assets/javascripts/controllers/poll-ui-builder.js.es6
index e5ca3d0..a653b81 100644
--- a/plugins/poll/assets/javascripts/controllers/poll-ui-builder.js.es6
+++ b/plugins/poll/assets/javascripts/controllers/poll-ui-builder.js.es6
@@ -15,8 +15,14 @@ export default Controller.extend({
   closedPollResult: "on_close",
   staffPollResult: "staff_only",
   pollChartTypes: [
-    { name: BAR_CHART_TYPE.capitalize(), value: BAR_CHART_TYPE },
-    { name: PIE_CHART_TYPE.capitalize(), value: PIE_CHART_TYPE }
+    {
+      name: I18n.t("poll.ui_builder.poll_chart_type.bar"),
+      value: BAR_CHART_TYPE
+    },
+    {
+      name: I18n.t("poll.ui_builder.poll_chart_type.pie"),
+      value: PIE_CHART_TYPE
+    }
   ],
 
   pollType: null,
diff --git a/plugins/poll/config/locales/client.en.yml b/plugins/poll/config/locales/client.en.yml
index ae4a258..035630f 100644
--- a/plugins/poll/config/locales/client.en.yml
+++ b/plugins/poll/config/locales/client.en.yml
@@ -118,6 +118,8 @@ en:
           label: Allowed groups
         poll_chart_type:
           label: Chart type
+          bar: Bar
+          pie: Pie
         poll_config:
           max: Max
           min: Min

GitHub sha: 7177b9d7

This commit has been mentioned on Discourse Meta. There might be relevant details there:

https://meta.discourse.org/t/how-to-translate-the-word-bar-from-polls-german-language-problem/149568/4